keepalived 安装

yum install -y openssl-devel
cd /usr/tmp
wget http://www.keepalived.org/software/keepalived-1.2.2.tar.gz  
tar xvzf keepalived-1.2.2.tar.gz 
cd keepalived-1.2.2  
#./configure --disable-fwmark --prefix=/usr/local/keepalived 
./configure --prefix=/usr/local/keepalived
configure: error: Popt libraries is required
yum install popt-devel

make && make install
cp /usr/local/keepalived/etc/rc.d/init.d/keepalived /etc/init.d/
cp /usr/local/keepalived/etc/sysconfig/keepalived /etc/sysconfig/
mkdir /etc/keepalived/
cp /usr/local/keepalived/etc/keepalived/keepalived.conf /etc/keepalived/
cp /usr/local/keepalived/sbin/keepalived /usr/sbin/

chmod +x /etc/init.d/keepalived
chkconfig --add keepalived
chkconfig keepalived on

mv /etc/keepalived/keepalived.conf /etc/keepalived/keepalived.conf.bak
vim /etc/keepalived/keepalived.conf 

标签: keepalived, 高可用

非特殊说明,本博所有文章均为博主原创。

最新文章

发表评论