centos6.9以上fab出现 Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.

使用之前centos 6.9的笔记, pip install pycrypto 部署后,运行fab -f b.py deploy出现了报错

Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.

解决方法是

wget --no-check-certificatehttps://ftp.gnu.org/gnu/gmp/gmp-6.0.0a.tar.bz2
tar -xvjpf gmp-6.0.0a.tar.bz2
cd gmp-6.0.0
./configure 
make 
make check
make install

wget --no-check-certificate https://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-2.6.1.tar.gz
tar -zxvf pycrypto-2.6.1.tar.gz
cd pycrypto-2.6.1
./configure
python setup.py install

标签: none

非特殊说明,本博所有文章均为博主原创。

最新文章

发表评论