首页 / 故障排查 / 解决vs2012等老版软件安装sqlite数据库驱动出现版本不兼容的问题

解决vs2012等老版软件安装sqlite数据库驱动出现版本不兼容的问题

2024-03-22 15:51:20故障排查 阅读 134
vs2012等老版软件安装sqlite数据库驱动基本上很残忍,好不容易解决NUGET联网问题,竟然提示架构版本与 NuGet 的版本不兼容。请通过 http://go.microsoft.com/fwlink/?LinkId=213942 将 NuGet 升级到最新版本

首先解决联网问题,以上截图也是联网之后才得以搜索出结果。

启动NuGet控制台

菜单“工具” - “库程序包管理器”-“库程序员管理器控制台” ,之后在vs软件底部会出现控制台


键入“get-help NuGet”以查看所有可用的 NuGet 命令。
PM> [Net.ServicePointManager]::SecurityProtocol=[Net.ServicePointManager]::SecurityProtocol-bOR [Net.SecurityProtocolType]::Tls12
为了找到合适的版本,小编进行了不少版本号盲猜,没成功。 最终在网页搜索,把时间限定在2013年,才搜到了可用的sqlite版本号 1.0.88.0,并成功安装。



PM> NuGet\Install-Package System.Data.SQLite -Version 1.0.88.0

已成功安装“System.Data.SQLite 1.0.88.0”。
已成功将“System.Data.SQLite 1.0.88.0”添加到 computermanage。


本文《解决vs2012等老版软件安装sqlite数据库驱动出现版本不兼容的问题》由爱思考吧 isres.com 分享,转载请注明出处。本文网址:https://www.isres.com/jingyan2/267.html

本站主要收集测评能够节省时间和提升效率的软件工具并分享使用与学习的过程和感受,任何情况下用户都需遵守所使用软件资源的相关协议。与《解决vs2012等老版软件安装sqlite数据库驱动出现版本不兼容的问题》有关的本站文章及资源仅供个人学习交流使用,相关资源请下载后24小时内删除,请勿用于其它用途,因此产生的任何问题由您自行承担。

猜你喜欢